Can't connect to C-Gate2 from Toolkit - localhost access error

Discussion in 'C-Bus Toolkit and C-Gate Software' started by Darren Hunter, Oct 14, 2005.

  1. Darren Hunter

    Darren Hunter

    Joined:
    May 18, 2005
    Messages:
    19
    Likes Received:
    0
    Hi

    I have this weird problem no. My Toolkit 1.1.6 was working fine a few weeks ago. It now give this error:

    Clipsal C-Gate(TM) v2.3.25 (build 2057)
    Warning: unknown parameter clock.updtate-interval
    License file found:
    Customer Name: PUBLIC
    Location: PUBLIC
    License type: PUBLIC
    Network licenses: 2
    Expiry: 1 January 2100
    Total network licenses: 2
    20051014-161845 974 access - Can not resolve address: localhost on line interfac
    e in access control file: C:\CLIPSAL\C-Gate2\config\access.txt
    20051014-161845 805 null - Access control refused load change connection from /
    127.0.0.1

    I have upgrade to Toolkit 1.1.8 and still same problem.

    The localhost (127.0.0.1) is to simple to go wrong. I can ping it. I have checks my 'hosts' file and it is fine too.

    I have stopped the MS firewall and rebooted. Still the same error.

    Must be something blocking access on my PC but I can't find it.

    Any help appreciated as this is killing me - too simple to go wrong.

    Thanks
    Darren
     
    Darren Hunter, Oct 14, 2005
    #1
    1. Advertisements

  2. Darren Hunter

    Richo

    Joined:
    Jul 26, 2004
    Messages:
    1,257
    Likes Received:
    0
    Location:
    Adelaide
    Could you paste a copy of the Acces.txt file here (or attach a copy) if there is sesative information in it then edit out the sensative stuff.
     
    Richo, Oct 14, 2005
    #2
    1. Advertisements

  3. Darren Hunter

    Darren Hunter

    Joined:
    May 18, 2005
    Messages:
    19
    Likes Received:
    0
    the content of access.txt

    ##C-Gate Server Access Control File
    ## This file was written automatically by a command issued to the server
    ## Created:Tue Oct 05 16:22:26 CST 2004
    ## File name: C:\clipsal\c-gate\config\access.txt
    interface 0:0:0:0:0:0:0:1 Program
    interface 127.0.0.1 Program
    interface localhost Program
    ## End of access control file
     
    Darren Hunter, Oct 14, 2005
    #3
  4. Darren Hunter

    Darren Hunter

    Joined:
    May 18, 2005
    Messages:
    19
    Likes Received:
    0
    still can't connect

    I have now unloaded quite a few services and stopped anything that doesn't really need to be running but still the same error.
    I have loaded Toolkit 1.1.8 on another machine and it communicates fine via my CNI.
    Is there anything else I should try?
    Is there anything I could add to the access.txt?

    thanks
    Darren
     
    Darren Hunter, Oct 18, 2005
    #4
  5. Darren Hunter

    ramon

    Joined:
    Aug 3, 2004
    Messages:
    19
    Likes Received:
    0
    why not just comment out the localhost entry in access.txt ? eg.

    ##C-Gate Server Access Control File
    ## This file was written automatically by a command issued to the server
    ## Created:Tue Oct 05 16:22:26 CST 2004
    ## File name: C:\clipsal\c-gate\config\access.txt
    interface 0:0:0:0:0:0:0:1 Program
    interface 127.0.0.1 Program
    ## interface localhost Program
    ## End of access control file

    alternatively add your LAN ip address to the file - probably a better bet eg. if your server address was 192.168.0.99 then -

    ##C-Gate Server Access Control File
    ## This file was written automatically by a command issued to the server
    ## Created:Tue Oct 05 16:22:26 CST 2004
    ## File name: C:\clipsal\c-gate\config\access.txt
    interface 0:0:0:0:0:0:0:1 Program
    interface 127.0.0.1 Program
    interface 192.168.0.99 Program
    ## interface localhost Program
    ## End of access control file

    then you should be able to telnet to the LAN ip address on port 20023.


    ... also if you want to get rid of the error "Warning: unknown parameter clock.updtate-interval", edit your config\C-Gateconfig.txt file and search for "updtate" and replace with "update".
     
    ramon, Oct 19, 2005
    #5
  6. Darren Hunter

    Darren Hunter

    Joined:
    May 18, 2005
    Messages:
    19
    Likes Received:
    0
    Thanks Ramon - I'll try those things and revert

    BTW - I uninstalled all Clipsal software and Java last night and reinstalled just the Toolkit 1.1.8 (and Java included in that install) and I still have the same problem. This is very frustrating but I've borrowed a laptop from work and installed Toolkit and Piced and all is fine from it.
     
    Darren Hunter, Oct 20, 2005
    #6
  7. Darren Hunter

    Darren Hunter

    Joined:
    May 18, 2005
    Messages:
    19
    Likes Received:
    0
    Ramon Thanks for your help

    I simply commented out the localhost line from access.txt and all is well

    still a puzlle but I up and running

    many thanks
     
    Darren Hunter, Oct 20, 2005
    #7
  8. Darren Hunter

    SJH_Elect

    Joined:
    Mar 16, 2005
    Messages:
    10
    Likes Received:
    0
    Access Problems in 1.1.8

    I have the same problem

    I install new version 1.1.8 on top of 1.1.6 & 7 and found that I couldn't access the program with the same c-gate errors.

    I unistalled and went back to 1.1.6 & 7, and had no problems (complete removal of c-gate directory)

    The same thing if install on fresh machine no problems

    Is there any chance that in the install of the software that something doesn't upgrade to new version of the software?

    Thanks
     
    SJH_Elect, Oct 25, 2005
    #8
  9. Darren Hunter

    ashleigh Moderator

    Joined:
    Aug 4, 2004
    Messages:
    2,348
    Likes Received:
    3
    Location:
    Adelaide, South Australia
    I sounds to me like the PC has not been set up with the name "localhost" as a known host name.

    Normally, when TCP/IP services are installed, the host name "localhost" is installed and aliased to 127.0.0.1. This is part of Windows, and not anything to do with the install of Toolkit.

    It seems like TCP/IP might not be set up quite right on some of your machines, though why this should be is a bit of a mystery. It is POSSIBLE that your TCP/IP options have not been set to look up host names in the LMHOSTS file.

    Commenting out the localhost line from the c-gate access.txt will prevent the attempt to look up the host name, and then, as you see, its OK.

    The long term solution might be to change the default access file shipped with C-Gate. This has been entered into the defect database, and we will investigate to see if we can roll a permanent fix into a future toolkit release.
     
    Last edited by a moderator: Oct 26, 2005
    ashleigh, Oct 26, 2005
    #9
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.