Universal Dimmer - 1 Channel Erratic

Discussion in 'C-Bus Wired Hardware' started by ss1987, May 14, 2024.

  1. ss1987

    ss1987

    Joined:
    Apr 9, 2022
    Messages:
    24
    Likes Received:
    1
    Location:
    Melbourne
    Hi all,
    Just wondering if anyone has had any issues with dimmer channels behaving erratically.
    I have a few 4 channel universal dimmers which all dim LED downlights without too much trouble.
    There is however one channel which struggles to provide smooth dimming.
    When I turn the channel on, the lights often flash on at 100% before turning off for a few seconds and eventually turning back on to the assigned brightness.
    I plan to swap these lights to another channel at some point just to confirm that it is a problem with the dimmer channel.

    On another note, has anyone tried the new digital dimmers? How do they compare with the old universal dimmers?
    Since the new dimmers come in an 8-channel model, I might be tempted to give one a go if they are noticeably better than the old units.
     
    ss1987, May 14, 2024
    #1
  2. ss1987

    Wonkey

    Joined:
    Aug 3, 2004
    Messages:
    400
    Likes Received:
    37
    Location:
    Adelaide
    I think you will find the issue with the erratic behaviour is related to the load and changing channel probably won't fix it.
    The Universal dimmer starts up in trailing edge mode and if the load appears to be an inductive load switches to leading edge mode.
    Sometimes the load when it starts up causes the dimmer to change mode and this is not needed and presents as this issue, I thought this problem had been solved years ago but I could be wrong.
    Suggestions:-
    Is this channel loaded with the same down lights and quantity as another channel. If so try changing just one of the down lights
    Single down light or low wattage total load try a load correction device (31LCDA) or maybe 31CAP.
    Finally just check you haven't got a poor electrical connection on that circuit
     
    Wonkey, May 15, 2024
    #2
  3. ss1987

    ss1987

    Joined:
    Apr 9, 2022
    Messages:
    24
    Likes Received:
    1
    Location:
    Melbourne
    I have the same good quality downlights and drivers all throughout the house which is why I suspect the dimmer is the culprit. There's 3 lights in this channel so I also doubt it's lack of load.
    I'll try and swap channels on the weekend to confirm.
     
    ss1987, May 15, 2024
    #3
  4. ss1987

    Conformist

    Joined:
    Aug 4, 2004
    Messages:
    765
    Likes Received:
    68
    Location:
    Adelaide, South Australia
    I've had some weird behavior with universal dimmers myself. I have seen issues with 6 LED downlights on a channel. Belkeive it or not, a load correction device fixed it. No idea why. Also seen situations where the lights take up to 10 seconds to come on. Again, the load correction device fixed it. If you have one, try adding it. Also found they work best tight next to the load (in a plug base).
     
    Conformist, May 15, 2024
    #4
  5. ss1987

    ss1987

    Joined:
    Apr 9, 2022
    Messages:
    24
    Likes Received:
    1
    Location:
    Melbourne
    Will do. Thanks :)
     
    ss1987, May 15, 2024
    #5
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.