Sunset/sunrise and NESS M1

Discussion in 'C-Touch/HomeGate/SchedulePlus/PICED Software' started by dsamson, Nov 14, 2017.

  1. dsamson

    dsamson

    Joined:
    Aug 23, 2004
    Messages:
    41
    Likes Received:
    1
    Location:
    Sydney
    Hi
    I have a C-Bus system connected to a Ness M1 using the C-Bus interface V3.
    The system has been running for more than 4 years and every year I have an issue with the sunset/sunrise schedules which are off by an hour during daylight savings period.
    I have checked the log file and realised that when the Ness system is broadcasting the time, it is resetting the daylight saving offset created by the PAC controller. Even though the time is correct as it is synced from the NTP because the offset sent by Ness is 0, the sunset/sunrise events controlled by the PAC are off by an hour.
    I like the fact that the time is accurate but it is annoying that is affecting the schedules during summer time.

    Has anybody found a workaround to this issue?

    Thanks.
     
    dsamson, Nov 14, 2017
    #1
    1. Advertisements

  2. dsamson

    Ashley

    Joined:
    Dec 1, 2005
    Messages:
    737
    Likes Received:
    20
    Location:
    Adelaide, Australia
    Unfortunately the M1 Cbus interface implements the cbus time protocol poorly so I ended up just disabling it. (I have a colour touchscreen that acts as an ntp server). About your only choice is to disable automatic dst in the M1 then select a time zone 1 hour ahead at the start of DST then set it back at the end. At least you only have to adjust it twice a year when you do all the other clocks :)
     
    Ashley, Nov 14, 2017
    #2
    1. Advertisements

  3. dsamson

    dsamson

    Joined:
    Aug 23, 2004
    Messages:
    41
    Likes Received:
    1
    Location:
    Sydney
    I have fixed this issue, I think, by disabling the M1 interface to broadcast the time.
    I'll confirm when the daylight saving starts.
     
    dsamson, May 18, 2018
    #3
  4. dsamson

    ampcom

    Joined:
    Jul 19, 2014
    Messages:
    23
    Likes Received:
    0
    Location:
    Sydney, Australia
    Hello,
    If your M1 is connected to an Ethernet module (M1XEP) then you can get the M1 to sync to NTP via the "Time Server" Tab in the M1XEP Setup window.

    M1XEP_Time_Server.JPG

    Also note that M1 settings of "Sunrise/Sunset" and "Globals Daylight Savings" are also required to be set correctly.
    M1_Sunrise-Sunset.JPG
    M1_Globals_Daylight_Savings_Time.JPG
     
    ampcom, May 22, 2018
    #4
  5. dsamson

    Ashley

    Joined:
    Dec 1, 2005
    Messages:
    737
    Likes Received:
    20
    Location:
    Adelaide, Australia
    The problem isn't with the M1 time keeping, it's how the M1 Cbus interface implements the time protocol, which is poorly. It just broadcasts the time indiscriminately every 5 hours, it doesn't listen and respond to incoming time requests, and is doesn't handle the DST flag in the protocol correctly. Because it doesn't listen to incoming requests, if you set the time from any cbus device the M1 will just blast over it some time in the next 5 hours.
     
    Ashley, May 23, 2018
    #5
  6. dsamson

    dsamson

    Joined:
    Aug 23, 2004
    Messages:
    41
    Likes Received:
    1
    Location:
    Sydney
    Ashley is right. Everytime M1 broadcasts the time, it resets the DST flag and all events based on sunset/sunrise are off by an hour during daylight saving time. I have fixed this issue by disabling M1 interface to broadcast the time into C-Bus network and I use Schedule Plus PC instead to keep the C-Bus time accurate. WA QLD and NT do not have this issue as they are not using DST in summer.
     
    dsamson, May 24, 2018
    #6
    Mr Mark likes this.
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.