Shac and Hikvision Mjpeg stream

Discussion in 'C-Bus Automation Controllers' started by MTR, Dec 17, 2018.

  1. MTR

    MTR

    Joined:
    Dec 13, 2018
    Messages:
    3
    Likes Received:
    1
    Hi Guys,
    Has any one had any success pulling the Mjpeg stream from a Hikvision cameras and NVR to be able to be displayed on the shac interface. Supposedly there is a Mjpeg Sub-stream

    I have tried a few Hikvision Mjpeg URL streams but nothing will work for me.

    Thanks
     
    MTR, Dec 17, 2018
    #1
    zei20t likes this.
    1. Advertisements

  2. MTR

    Pie Boy

    Joined:
    Nov 21, 2012
    Messages:
    28
    Likes Received:
    3
    Location:
    New Zealand
    Hi MTR,

    Are you wanting to access the url stream from the camera directly or through an NVR as the url to each is different
    if you are wanting the substream this needs to be enabled and set up in the camera as well before access by the url stream
     
    Pie Boy, Jan 1, 2019
    #2
    1. Advertisements

  3. MTR

    zei20t

    Joined:
    Aug 18, 2010
    Messages:
    82
    Likes Received:
    0
    Location:
    Sydney, Australia
    I had this same problem. buried in the camera settings (Not on the NVR):

    Network -> Advanced Settings.
    "Integration Protocol"
    Tick the box that says "Enable Hikvision-CGI Authentication"
    I use "digest" authentication
    Click Save

    I changed my sub-stream to MPEG via:
    Video/Audio
    Hit the drop down box on "Stream Type" to Sub-Stream
    Change the Video Encoding to MPEG
    Click Save
     
    zei20t, Jan 7, 2019
    #3
  4. MTR

    zei20t

    Joined:
    Aug 18, 2010
    Messages:
    82
    Likes Received:
    0
    Location:
    Sydney, Australia
    zei20t, Jan 7, 2019
    #4
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.