Set Value of UserParameter by Referencing Keyword

Discussion in 'C-Bus Automation Controllers' started by pspeirs, Nov 15, 2019.

  1. pspeirs

    pspeirs

    Joined:
    Nov 23, 2013
    Messages:
    139
    Likes Received:
    5
    Location:
    Sydney
    Hi All,

    I want to set the value of a userparam by using the keyword rather than the object name. I can read a userparam via keyword however don't seem to be able to write to it.

    In addition, the sqlite database doesn't appear to contain the name of the userparam anywhere, either in 'objects' or 'objecttags' which look like the only table the data is likely to reside in.

    In short, which table would contain the actual name of the userparameter?


    Cheers,
    Paul
     
    pspeirs, Nov 15, 2019
    #1
    1. Advertisements

  2. pspeirs

    Pie Boy

    Joined:
    Nov 21, 2012
    Messages:
    32
    Likes Received:
    5
    Location:
    New Zealand
    I struck this also, after having a poke around in the database,in 'objects' and 'objecttags' most of my user param's were NULL in the name column, even thought they have a name in the web ui, although there were a few that followed the 0/250/1 format - these seemed to be objects mapped to modbus points, i wonder if a db command to write the name would work?

    it seems like there is a disconnect between the Objects and the Tag map in the UI
    and the parameter Name in the database.
     
    Pie Boy, Nov 18, 2019
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.