Ness D16 w miniCentral Arm Home Mode

Discussion in 'General Discussion' started by jasonson, Jul 6, 2017.

  1. jasonson


    Feb 17, 2014
    Likes Received:
    First time installing a ness Dx16 with a miniCentral.

    How can I arm the stay (home) mode from the eDlt in the master bedroom. Save me running a wire from the panel downstairs (impossible to do now)

    I have a PACA if logic is needed.
    jasonson, Jul 6, 2017
    1. Advertisements

  2. jasonson


    Aug 3, 2004
    Likes Received:
    Down load diagnostic utility, connect to C-Bus and on the Security Slave tab you will see Arm set this to Night (home) Mode and see if the alarm sets. I don't have a mini central to try it on
    If it works then setting application 208, group address 162 to 1% over 4 sec will set the alarm into home mode, not unset it.

    The challenge will be setting up the application and group address in toolkit to allow you to use it in logic.
    Copy your project and save it just in case things go wrong
    I created a new application with in the lighting range and called it Security. (Application 49 for example will do) then added group address 162.
    Close toolkit and c-gate
    I then hacked the tag database (Clipsal | C-Gate 2| Tag | Project name) by opening the project using Note.

    Search for 49 (the Application number I used)

    and changed it to 208
    then saved and closed.
    Open tool kit and confirm the application number has changed.

    Another idea may be to use earlier software c-bus V2, program a key input with the application and GA then put that input on the network and see if TK adds it, have not tried it.

    I got the logic running just can't test the alarm bit.
    Example logic:

    once (GetLightingState("Group 1") = ON) then
    SetCBusLevel("Local", "Security", "Group 162", 1%, "4s");


    On the eDLT use a 1 sec timer for the lighting group you are going to use. This will allow the once command to function correctly.

    Alternative solution use a radio remote if I remember correctly holding the arm button on the remote for a couple of secs "home sets" the alarm

    Last edited by a moderator: Jul 6, 2017
    Wonkey, Jul 6, 2017
    1. Advertisements

  3. jasonson

    daniel C-Busser Moderator

    Jul 26, 2004
    Likes Received:
    It may not be necessary to edit the project file by hand.

    In Toolkit go to File | Preferences | Compatibility tab, and select the checkbox "Allow creation of legacy C-Bus Applications". You should then be able to add Application 208 to your network, it will even adopt the name "Security" automatically.

    You can then disable the checkbox again to get rid of the big warning label, but the application will remain in your project.
    daniel, Jul 14, 2017
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.