CTouch Screen Mk1 Connection Issues

Discussion in 'C-Touch/HomeGate/SchedulePlus/PICED Software' started by The Old Scholar, May 14, 2024.

  1. The Old Scholar

    The Old Scholar

    Joined:
    Nov 27, 2004
    Messages:
    3
    Likes Received:
    0
    Hi

    This is a bit of a long shot given the age of this screen, but I am trying to upload a new project to it and cannot get PICED to connect.

    Model: SC5000CT
    Hardware version: 1
    C-Bus Firmware: 4.3
    C-Touch Firmware: 3.8
    Connection: FTDI USB with RJ45 connected (black (GND to PIN 4), yellow (Rx to PIN 5) and orange (Tx to PIN 6)) https://uk.rs-online.com/web/p/interface-adapters-converters/6877828?gb=s (but I've tried lots of others too)
    PICED: 4.14.2 (but tried many previous versions)
    Toolkit: 1.16.4 (again tried various versions)

    I've read lots of useful threads here, especially around issues with usb-serial cables and I've tested the serial connection via PUTTY with successful results. My knowledge here is weak, but I have connected Rx and Tx together, change the connection to serial and see what I type in PUTTY - if I've missed the point here, please point me in the right direction.

    When I try to upload a project in PICED I get the 'connecting to unit via COM X', followed by the 'Could not connect to unit. Communications failed. Select Change Port to change the port and try again' messages. I've tried connecting on a Windows 11 VM on my MAC (Intel) and a Windows 10 laptop and get exactly the same results.

    It's been many years since I've updated the screen, but I'm sure I've used a similar USB-serial cable previously successfully, but MAC/PC hardware has changed.

    I believe the PICED and Toolkit versions I am using are compatible, but I can't find a table on the Schneider site, as there used to be on the old Clipsal downloads site.

    Any ideas of what else I can try? Any pointers would be much appreciated.

    Thanks

    Ash
     
    The Old Scholar, May 14, 2024
    #1
  2. The Old Scholar

    Wonkey

    Joined:
    Aug 3, 2004
    Messages:
    403
    Likes Received:
    37
    Location:
    Adelaide
    Ensure the Baud rate of the serial adapter is set to 9600.
    The C-Touch needs to be powered from a C-Bus network to transfer a project.
     
    Wonkey, May 19, 2024
    #2
  3. The Old Scholar

    Trevor

    Joined:
    Nov 22, 2018
    Messages:
    310
    Likes Received:
    25
    Location:
    Melbourne Victoria
    If you want to load a project using piced over cbus you have to set the correct address, i can't remember if its 1 or 0 but piced will expect to find it on the one it wants, you have to use toolkit to change it
     
    Trevor, May 19, 2024
    #3
Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.