CBus OPC to Citect

Discussion in 'C-Bus OPC Server Software' started by AAM, Jan 12, 2011.

  1. AAM

    AAM

    Joined:
    Jan 11, 2011
    Messages:
    9
    Likes Received:
    0
    Location:
    Wellington
    Sorry to cause confusion,
    having included those lines of code in the Citect.ini file has solved all the issues. I was picking brains to understand why without those lines of code, communication was still possible in one direction. The recent screen shots were of the fixed configuration, with the updated Citect.ini file, in contrast to the earlier screen shots with errors, and without the manual editing of the Citect.ini file.

    The problem has been solved on the bench, although we install next week...
    Cheers, Adam
     
    AAM, Jan 18, 2011
    #21
    1. Advertisements

  2. AAM

    DarrenH

    Joined:
    Dec 19, 2008
    Messages:
    21
    Likes Received:
    0
    Location:
    Adelaide, South Australia
    Ok, no worries. Fingers crossed for the installation!

    Darren.
     
    DarrenH, Jan 18, 2011
    #22
    1. Advertisements

  3. AAM

    AAM

    Joined:
    Jan 11, 2011
    Messages:
    9
    Likes Received:
    0
    Location:
    Wellington
    Hey all,
    Just to let you know that the Citect - OPC - CBus installation went in successfully. Thank you all for your time and support in this problem!

    Just a final footnote:

    Avoid using forward slash ("/") in naming your CBus groups if there may be any possibility you will be using OPC with your CBus project. This, and no doubt other characters cannot be recognised by OPC and are replaced with an underscore ("_").

    Cheers, Adam
     
    AAM, Jan 27, 2011
    #23
  4. AAM

    DarrenH

    Joined:
    Dec 19, 2008
    Messages:
    21
    Likes Received:
    0
    Location:
    Adelaide, South Australia
    That's great news Adam.

    For anyone that's interested, OPC does not allow the following punctuation:

    : , / \ ! " ` ? ' | # .

    It may also help to know that space characters are fine.
     
    DarrenH, Jan 28, 2011
    #24
  5. AAM

    HSLee

    Joined:
    Dec 16, 2008
    Messages:
    30
    Likes Received:
    0
    Hi Guys

    Currently doing a CItect v7.2 with CBus OPC, may i know anybody here success to control by citect v7.2? I can't communicate , i believe something wrong in CItect board, port, IO server define.

    Thanks
     
    HSLee, Apr 24, 2011
    #25
  6. AAM

    DarrenH

    Joined:
    Dec 19, 2008
    Messages:
    21
    Likes Received:
    0
    Location:
    Adelaide, South Australia
    HSLee,

    Have you tried using an alternative OPC client? The Softing OPC Toolbox Demo Client is available under the C-Bus OPC Server installation directory:

    Test OPC Client Installer\OPCDemoClientE.msi

    Let us know if that works.
     
    DarrenH, Apr 27, 2011
    #26
  7. AAM

    HSLee

    Joined:
    Dec 16, 2008
    Messages:
    30
    Likes Received:
    0
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.