C-Bus Forums  

Go Back   C-Bus Forums > C-Bus Integration > C-Gate Developers

The C-Bus Community Forums is place where C-Bus users can share information and help others with C-Bus. From time to time you will see Clipsal staff on the forums, but this is not an official support channel. If you really need help contact the official support services of Clipsal. More information about the purpose of this forum is available here.

Reply
 
Thread Tools Display Modes
  #21  
Old 06 Jan 14, 02:51 PM
cheekymonkey cheekymonkey is offline
New Member
 
Join Date: Mar 2013
Location: Perth, WA
Posts: 11
Default

I'm not sure if you worked this out but now my big project of building the dining table for xmas lunch and the associated celebrations are over I've had some time to play and connected my 5000SM2 directly to the Pi.

The connections I used were

Code:
 Pi pin               5000SM2 pin
 
 1 (3.3v)	->    7
 6 (GND)        ->    9 (Common)
 8 (TX)         ->    8 (RX)
 10 (RX)	->    10 (TX)
The console needs to be disabled on the pi and the safest way is to install rpi-serial-console, simply run:

Code:
sudo wget https://raw.github.com/lurch/rpi-serial-console/master/rpi-serial-console -O /usr/bin/rpi-serial-console && sudo chmod +x /usr/bin/rpi-serial-console
Then to disable the serial console, simply run:
Code:
sudo rpi-serial-console disable
Update /etc/init.d/ser2sock so the start line changes from
Code:
/usr/local/bin/ser2sock -d -p 10001 -s /dev/ttyUSB0 -b 9600
to
Code:
/usr/local/bin/ser2sock -d -p 10001 -s /dev/ttyAMA0 -b 9600
The pi then needs to be rebooted for the changes to take effect

Last edited by cheekymonkey; 06 Jan 14 at 02:55 PM. Reason: changed connection to code so it formats better
Reply With Quote
  #22  
Old 25 Jul 14, 12:29 PM
zx9 zx9 is offline
Member
 
Join Date: Jun 2009
Location: Melbourne
Posts: 47
Default intermitted problems with ser2sock

Hi,

following the excellent guide I got my Pi working pretty easily and have since moved all my logic onto my Pi using nodejs.

The only issue I am having is now and again the cbus connection USB to serial via ser2sock falls over. This seems random and it may stay up for a month or only a day. When it does fail cgate reports 'restarting stuck transmitter' errors and the only way to fix it is to stop & restart the ser2sock service. Before I go a build the detect&restart functionality into nodejs I though I would ask if anyone has experienced this behaviour and is there a fix?

thanks,
Reply With Quote
  #23  
Old 09 Sep 14, 01:55 PM
zx9 zx9 is offline
Member
 
Join Date: Jun 2009
Location: Melbourne
Posts: 47
Default

Quote:
Originally Posted by zx9 View Post
Hi,

following the excellent guide I got my Pi working pretty easily and have since moved all my logic onto my Pi using nodejs.

The only issue I am having is now and again the cbus connection USB to serial via ser2sock falls over. This seems random and it may stay up for a month or only a day. When it does fail cgate reports 'restarting stuck transmitter' errors and the only way to fix it is to stop & restart the ser2sock service. Before I go a build the detect&restart functionality into nodejs I though I would ask if anyone has experienced this behaviour and is there a fix?

thanks,
An update for anyone who may come across a similar problem. A couple of days after I posted the above I went and downloaded the latest ser2sock from github. It's now been 6 weeks with no problems so fingers crossed i believe it's resolved the issue.
Reply With Quote
  #24  
Old 06 May 17, 10:41 PM
DarylMc DarylMc is offline
Senior Member
 
Join Date: Mar 2006
Location: Brisbane
Posts: 901
Default

It's been 5 years since my original post and I finally have CGate running on rapsberry pi
I can't even remember why I wanted to do it 5 years ago but it is very useful for homebridge-cbus.

My sincere thanks to everyone who has contributed and made that possible.

Last edited by DarylMc; 07 May 17 at 02:54 AM.
Reply With Quote
  #25  
Old 06 Oct 17, 01:19 AM
IanCun IanCun is offline
Administrator
 
Join Date: Sep 2012
Location: UK
Posts: 70
Default

Just a heads up for anyone following this guide on a RPi3 or Pi Zero W, using a 5000SM/2 via /dev/TTYAMA0. You'll need to disable bluetooth and swap serial ports using this guide to get it working:

https://spellfoundry.com/2016/05/29/...ncluding-pi-3/
Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
C-Gate comms on Ubuntu Linux more-solutions C-Bus Toolkit and C-Gate Software 0 06 Jul 11 09:56 PM
piced startup problems - no cgate phcjpp C-Touch/HomeGate/SchedulePlus/PICED Software 2 05 Mar 10 06:35 PM
Mac OSX automation paddy2042 General Discussion 32 08 Sep 09 12:16 AM
Toolkit, Homegate and CGate NickLocke C-Bus Toolkit and C-Gate Software 2 08 Mar 05 04:51 AM
PCI SmartMode and CGate cueman C-Bus Toolkit and C-Gate Software 7 19 Jan 05 08:23 AM


All times are GMT +10.5. The time now is 04:51 PM.


Powered by vBulletin® Version 3.7.4
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.